Acquisition Explorer - delayed deliveries

Incident Report for HouseCanary

Resolved

This issue has now been resolved.
Posted Apr 10, 2025 - 16:30 PDT

Identified

We have identified an issue that is resulting in a delay for clients that receive deliveries related to Acquisition Explorer. We will post an update once the issue has been resolved.
Posted Apr 10, 2025 - 16:09 PDT
This incident affected: Acquisition Explorer.