Property Explorer Performance Issues
Incident Report for HouseCanary
Resolved
This incident has been resolved.
Posted Apr 05, 2021 - 12:22 PDT
Investigating
We are currently investigating performance issues with Property Explorer related to downloading PDFs and saving reports.
Posted Apr 05, 2021 - 10:50 PDT
This incident affected: Property Explorer - Web Application and Property Explorer - API.